Вы здесь: Hi-Tech новинки, гаджеты, новые технологии, электроника, робототехника » Информационные технологии » Создание приложений для iPhone

Поиск по сайту
10-09-2012, 11:05
При разработке приложений под iPhone возникает естественное желание использовать самую последнюю версию из-за Storyboard и ARC. Но стоит ли отказываться от поддержки ранних версий iOS, ведь далеко не все устройства поддерживают iOS 5.0 и выше. Ведь на сегодняшний день Apple уже дали разработчикам 3 бета-версию новой мобильной операционной системы iOS 6 и производители iPhone обещают выпустить еще несколько бета-версий до финального релиза в этом году.

Создание приложений для iPhone

Небольшой перечень мобильных устройств, ограниченных версиями iOS:
версия 3.1.3 - iPhone первого поколения;
версия 4.2.1 - iPhone 3G;
версия 5.0 - iPhone 3GS, iPhone 4, iPhone 4S, iPod touch, iPad, iPad 2;
версия 5.1 (бета-версия) - iPhone 3GS, iPhone 4, iPhone 4S, iPod touch, iPad, iPad 2.

Сейчас с завершения продаж мобильных устройств использующих версию iOS 3.1.3 уже прошло 4 года, что значительно превышает срок пользования данными устройствами (средний срок - 2 года) и наверняка пользователи продолжающие пользоваться этими устройствами не приобретают приложения в iTunes Store.
Удешевленная версия iPhone 3G не продается с лета 2010 года. Так же средний срок их использования - 2 года. Количество этих устройств на вторичном рынке уменьшается по естественным причинам с выходом из строя аккумуляторных батарей и не аккуратного использования.
На данный момент версией iOS 4.3 и выше пользуются до 90% владельцев мобильных устройств, но они могут её обновить до 5 версии и выше без каких либо проблем.

Следовательно, разрабатывать простые приложения необходимо под версию iOS 4.2, но на перспективу следует переходить на iOS 5.0 или даже 6.0.
Источник: http://gadgettoday.ru

 
Просмотров:
© 2009–2017 GadgetToday.ru
При полном или частичном использовании публикаций ссылка на GadgetToday.ru обязательна.